summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
2 files changed, 3 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e91a670..180a3f1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
dgit (2.6~) unstable; urgency=medium
- *
+ * Always honour --curl= and --curl:.
--
diff --git a/dgit b/dgit
index f1f952a..2dd45be 100755
--- a/dgit
+++ b/dgit
@@ -955,7 +955,7 @@ sub pool_dsc_subpath ($$) {
sub archive_api_query_cmd ($) {
my ($subpath) = @_;
- my @cmd = qw(curl -sS);
+ my @cmd = (@curl, qw(-sS));
my $url = access_cfg('archive-query-url');
if ($url =~ m#^https://([-.0-9a-z]+)/#) {
my $host = $1;
@@ -1321,7 +1321,7 @@ sub check_for_git () {
my $suffix = access_cfg('git-check-suffix','git-suffix',
'RETURN-UNDEF') // '.git';
my $url = "$prefix/$package$suffix";
- my @cmd = (qw(curl -sS -I), $url);
+ my @cmd = (@curl, qw(-sS -I), $url);
my $result = cmdoutput @cmd;
$result =~ s/^\S+ 200 .*\n\r?\n//;
# curl -sS -I with https_proxy prints