summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c9e290..1309610 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,8 @@ dgit (1.5~~) unstable; urgency=medium
directory before running rmtree on it. Closes:#796773.
* Do not call "warn" on failure of cleanup handler in END block
(since warn has been made fatal and aborts the cleanup chain).
+ * Print better error message (with `fail' rather than `die') if
+ `dgit clone' cannot create the destination directory.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 507be27..9bdd207 100755
--- a/dgit
+++ b/dgit
@@ -1706,7 +1706,7 @@ sub clone ($) {
canonicalise_suite();
badusage "dry run makes no sense with clone" unless act_local();
my $hasgit = check_for_git();
- mkdir $dstdir or die "$dstdir $!";
+ mkdir $dstdir or fail "create \`$dstdir': $!";
changedir $dstdir;
runcmd @git, qw(init -q);
my $giturl = access_giturl(1);