summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit6
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index f035107..b6dd3b2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -51,6 +51,9 @@ dgit (0.23~) unstable; urgency=low
options, rather than thinking the user meat an empty value.
Closes:#763332.
+ * Reject (rather than ignoring) further options merged witht -wn, -wg,
+ -wd.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 839f93f..7cbef4e 100755
--- a/dgit
+++ b/dgit
@@ -2732,13 +2732,13 @@ sub parseopts () {
} elsif (m/^-[vdCk]$/) {
badusage
"option \`$_' requires an argument (and no space before the argument)";
- } elsif (s/^-wn//s) {
+ } elsif (s/^-wn$//s) {
push @ropts, $&;
$cleanmode = 'none';
- } elsif (s/^-wg//s) {
+ } elsif (s/^-wg$//s) {
push @ropts, $&;
$cleanmode = 'git';
- } elsif (s/^-wd//s) {
+ } elsif (s/^-wd$//s) {
push @ropts, $&;
$cleanmode = 'dpkg-source';
} else {