summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit1
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8d56188..6bac07b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (4.3~) unstable; urgency=medium
- *
+ Bugfixes:
+ * dgit archive-api-query: Avoid crashing due to lack of $isuite.
+ This breaks the infrastructure. Closes:#886592.
--
diff --git a/dgit b/dgit
index e86e398..27dcf1c 100755
--- a/dgit
+++ b/dgit
@@ -6456,6 +6456,7 @@ sub pre_archive_api_query () {
sub cmd_archive_api_query {
badusage "need only 1 subpath argument" unless @ARGV==1;
my ($subpath) = @ARGV;
+ local $isuite = 'DGIT-API-QUERY-CMD';
my @cmd = archive_api_query_cmd($subpath);
push @cmd, qw(-f);
debugcmd ">",@cmd;