summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit6
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index d362977..1097b77 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,7 +10,8 @@ dgit (1.4~~) UNRELEASED; urgency=low
the error message. (This has been broken forever.)
* In dgit(7), discuss binaries and documentation present in upstream but
removed by rules clean.
- * Detect and reject git trees containing debian/source/local-options.
+ * Detect and reject git trees containing debian/source/local-options
+ or debian/source/local-patch-header.
* In --dry-run mode, _do_ actually run dpkg-source --commit so that we
actually do construct the quilt fixup commit; instead, honour
--dry-run by avoiding pulling it back to your HEAD.
diff --git a/dgit b/dgit
index f4e2abf..a49c766 100755
--- a/dgit
+++ b/dgit
@@ -1762,8 +1762,10 @@ sub check_not_dirty () {
failedcmd @cmd;
}
- if (stat_exists "debian/source/local-options") {
- fail "git tree contains debian/source/local-options";
+ foreach my $f (qw(local-options local-patch-header)) {
+ if (stat_exists "debian/source/$f") {
+ fail "git tree contains debian/source/$f";
+ }
}
}