summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xtests/run-all5
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 2c30556..b34b4a0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,6 +15,10 @@ dgit (5.2~) unstable; urgency=medium
explanation, rather than looping with a false coplaint about git
fetch. Closes:#871317.
+ test suite:
+ * Use nproc(1) rather than Sys::CPU. This is more portable and does not
+ depend on libsys-cpu-perl being installed. Closes:888496.
+
--
dgit (5.1) unstable; urgency=medium
diff --git a/tests/run-all b/tests/run-all
index cfa5ce2..f72b9fa 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -5,9 +5,8 @@ set -e
set -o pipefail
-set +e
-jcpus=`perl -MSys::CPU -we 'printf "-j%d\n", 1.34 * Sys::CPU::cpu_count()'`
-set -e
+ncpus=$(nproc || echo 1)
+jcpus=-j$(( ncpus * 134 / 100 ))
if [ $# != 0 ]; then
set TESTSCRIPTS="$*"