summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdgit2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d381fc3..dee9276 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (0.10) unstable; urgency=low
+
+ * Create .pc/applied-patches - do not empty it (!)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 25 Aug 2013 00:51:50 +0100
+
dgit (0.9) unstable; urgency=low
* New cleaning arrangements.
diff --git a/dgit b/dgit
index 3f9dd97..7352371 100755
--- a/dgit
+++ b/dgit
@@ -1017,7 +1017,7 @@ END
runcmd_ordryrun @dpkgsource, qw(--commit .), $patchname;
}
- if (!open P, '>', ".pc/applied-patches") {
+ if (!open P, '>>', ".pc/applied-patches") {
$!==&ENOENT or die $!;
} else {
close P;