summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtests/tests/push-source-with-changes9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 2a123c3..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -23,7 +23,14 @@ t-dgit -C ../${p}_1.0_multi.changes push-source --new
t-expect-fail F:'tree contains uncommitted files' \
t-dgit build-source
-t-dgit -wddn build-source
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master