summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
-rw-r--r--tests/lib5
3 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 5543389..75515ee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (2.5~) unstable; urgency=medium
* Test suite bugfixes.
* Test suite: Introduce setup/gnupg, to work around #841143
and improve performance by amortising gnupg migration cost.
+ * Switch to new archive/ tag format by default, even in
+ non-split-brain mode.
--
diff --git a/dgit b/dgit
index 7ca97c5..6cdf8d2 100755
--- a/dgit
+++ b/dgit
@@ -551,7 +551,7 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit.default.ssh' => 'ssh',
'dgit.default.archive-query' => 'madison:',
'dgit.default.sshpsql-dbname' => 'service=projectb',
- 'dgit.default.dgit-tag-format' => 'old,new,maint',
+ 'dgit.default.dgit-tag-format' => 'new,old,maint',
# old means "repo server accepts pushes with old dgit tags"
# new means "repo server accepts pushes with new dgit tags"
# maint means "repo server accepts split brain pushes"
diff --git a/tests/lib b/tests/lib
index 39763c6..5d8e742 100644
--- a/tests/lib
+++ b/tests/lib
@@ -65,7 +65,7 @@ incoming = $tmp/incoming
run_dinstall = 0
END
-: ${tagpfx:=test-dummy}
+: ${tagpfx:=archive/test-dummy}
: ${suitespecs:=sid:unstable}
t-git-next-date () {
@@ -825,7 +825,7 @@ t-drs () {
t-git-config dgit-distro.test-dummy.git-url "ext::$troot/drs-git-ext %S "
t-git-config dgit-distro.test-dummy.git-check true
t-git-config dgit-distro.test-dummy.git-create true
- t-git-config dgit-distro.test-dummy.dgit-tag-format old,new
+ t-git-config dgit-distro.test-dummy.dgit-tag-format new,old,maint
cp $troot/gnupg/{dd.gpg,dm.gpg,dm.txt} $tmp/.
cp $troot/suites $tmp/.
cp $troot/suites $tmp/suites-master
@@ -852,6 +852,7 @@ t-newtag () {
t-git-config dgit-distro.test-dummy.dgit-tag-format new,maint
}
t-oldtag () {
+ export tagpfx=test-dummy
t-git-config dgit-distro.test-dummy.dgit-tag-format old
}