summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdgit2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7e2b85f..0f2d67c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (0.3~0.1) experimental; urgency=low
+
+ * This version appears to be able to push. We still need to test
+ fetching a dgit-based upload...
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 17 Aug 2013 09:18:04 +0100
+
dgit (0.2) experimental; urgency=low
* New version which might actually work but probably won't.
diff --git a/dgit b/dgit
index e4b1177..78b05f9 100755
--- a/dgit
+++ b/dgit
@@ -431,7 +431,7 @@ sub rev_parse ($) {
sub is_fast_fwd ($$) {
my ($ancestor,$child) = @_;
- my $mb = cmdoutput @git, qw(merge-base), $dsc_hash, $upload_hash;
+ my $mb = cmdoutput @git, qw(merge-base), $ancestor, $child;
return rev_parse($mb) eq rev_parse($ancestor);
}