summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit6
-rw-r--r--dgit.12
3 files changed, 7 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8a3490b..c108839 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -40,6 +40,7 @@ dgit (1.1~~) unstable; urgency=low
the user about how to retry. Closes:#793144.
* Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD. Closes:#793427.
* Slurp in entire git config, for better performance.
+ * With -DDDD, print out all gitcfg references (copious!)
--
diff --git a/dgit b/dgit
index bcb6a9c..56cee11 100755
--- a/dgit
+++ b/dgit
@@ -528,6 +528,8 @@ sub git_slurp_config () {
sub git_get_config ($) {
my ($c) = @_;
my $l = $gitcfg{$c};
+ printdebug"C $c ".(defined $l ? messagequote "'$l'" : "undef")."\n"
+ if $debuglevel >= 4;
$l or return undef;
@$l==1 or badcfg "multiple values for $c" if @$l > 1;
return $l->[0];
@@ -3185,8 +3187,10 @@ sub finalise_opts_opts () {
}
foreach my $c (access_cfg_cfgs("opts-$k")) {
- local ($debuglevel) = $debuglevel-2;
my $vl = $gitcfg{$c};
+ printdebug "CL $c ",
+ ($vl ? join " ", map { shellquote } @$vl : ""),
+ "\n" if $debuglevel >= 4;
next unless $vl;
badcfg "cannot configure options for $k"
if $opts_opt_cmdonly{$k};
diff --git a/dgit.1 b/dgit.1
index 2e862e3..1507d43 100644
--- a/dgit.1
+++ b/dgit.1
@@ -376,7 +376,7 @@ fixing up, dgit push will fail.
.TP
.BI -D
Prints debugging information to stderr. Repeating the option produces
-more output (currently, up to -DDD is meaningfully different).
+more output (currently, up to -DDDD is meaningfully different).
.TP
.BI -c name = value
Specifies a git configuration option, to be used for this run.