summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a60f35a..fc7d222 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -119,6 +119,8 @@ dgit (1.5~~) unstable; urgency=medium
* Many new tests (especially for new functionality).
* Add missing debhelper (>=8) to test suite's global Depends.
* tstunt arrangements: Fix mishandling of PERLLIB, etc.
+ * tstunt-parsechangelog: Produce Timestamp field (like official one
+ does, now).
--
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index 436591f..ba6ef54 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -60,7 +60,8 @@ for (;;) {
Maintainer: $1
Date: $2
END
- last;
+ print "Timestamp: " or die $!;
+ exec qw(date +%s -d), $2; die $!;
} elsif (m/^ --\s*$/) {
last;
} elsif (!m/\S/) {