summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit7
-rw-r--r--dgit.15
3 files changed, 13 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 0f1cff7..39bcbc5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (0.12) unstable; urgency=low
* Add Closes line for #720595 to changelog entry for 0.11.
* Improve error message for non-fast-forward push. Closes: #720896.
* New --ignore-dirty option to skip noncritical check. Closes: #720895.
+ * New --no-quilt-fixup option to suppress quilt fixup. RTFM.
--
diff --git a/dgit b/dgit
index 02acfa7..9602b98 100755
--- a/dgit
+++ b/dgit
@@ -37,6 +37,7 @@ our $dryrun = 0;
our $changesfile;
our $new_package = 0;
our $ignoredirty = 0;
+our $noquilt = 0;
our $existing_package = 'dpkg';
our $cleanmode = 'dpkg-source';
@@ -804,6 +805,10 @@ sub madformat ($) {
my ($format) = @_;
return 0 unless $format eq '3.0 (quilt)';
print "Format \`$format', urgh\n";
+ if ($noquilt) {
+ print "Not doing any fixup of \`$format' due to --no-quilt-fixup";
+ return 0;
+ }
return 1;
}
@@ -1197,6 +1202,8 @@ sub parseopts () {
badusage "unknown cleaning mode \`$1'";
} elsif (m/^--ignore-dirty$/s) {
$ignoredirty = 1;
+ } elsif (m/^--no-quilt-fixup$/s) {
+ $noquilt = 1;
} else {
badusage "unknown long option \`$_'";
}
diff --git a/dgit.1 b/dgit.1
index af18b0f..f97e458 100644
--- a/dgit.1
+++ b/dgit.1
@@ -352,6 +352,11 @@ This option may not work properly on `3.0 (quilt)' packages, as in
that case dgit needs to use and perhaps commit parts of your working
tree.
.TP
+.BR --no-quilt-fixup
+Do not fix up source format `3.0 (quilt)' metadata. If you use this
+option and the package did in fact need fixing up, dgit push will
+fail.
+.TP
.BI -D
Prints debugging information to stderr. Repeating the option produces
more output (currently, up to -DD is meaningfully different).