summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7a43446..577b81a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
dgit (1.3) unstable; urgency=low
- *
+ * In option parser test `@ARGV' not `length @ARGV'. Closes:#795710.
--
diff --git a/dgit b/dgit
index eb9a97c..62cd049 100755
--- a/dgit
+++ b/dgit
@@ -3161,7 +3161,7 @@ sub parseopts () {
my ($what) = @_;
@rvalopts = ($_);
if (!defined $val) {
- badusage "$what needs a value" unless length @ARGV;
+ badusage "$what needs a value" unless @ARGV;
$val = shift @ARGV;
push @rvalopts, $val;
}