summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 562e415..1cff277 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,8 @@ dgit (3.0~) unstable; urgency=medium
dgit-badcommit-fixup:
* Do not investigate symrefs. Closes:#850547.
+ * Improve debugging output a bit.
+
Test suite:
* Internal improvements.
* badcommit-rewrite: Fix operation using installed version of fixup.
diff --git a/dgit b/dgit
index 2427f72..5f37c11 100755
--- a/dgit
+++ b/dgit
@@ -659,7 +659,9 @@ sub git_get_config ($) {
my ($c) = @_;
foreach my $src (@gitcfgsources) {
my $l = $gitcfgs{$src}{$c};
- printdebug"C $c ".(defined $l ? messagequote "'$l'" : "undef")."\n"
+ printdebug"C $c ".(defined $l ?
+ join " ", map { messagequote "'$_'" } @$l :
+ "undef")."\n"
if $debuglevel >= 4;
$l or next;
@$l==1 or badcfg "multiple values for $c".