summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/lib5
-rwxr-xr-xtests/setup/gbp2gdr5
-rwxr-xr-xtests/tests/gdr-edits6
3 files changed, 9 insertions, 7 deletions
diff --git a/tests/lib b/tests/lib
index e226637..dd8c4d0 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1004,6 +1004,11 @@ t-commit () {
revision=$(( ${revision-0} + 1 ))
}
+t-dch-commit () {
+ dch "$@"
+ git commit -m "dch $*" debian/changelog
+}
+
t-git-config () {
git config --global "$@"
}
diff --git a/tests/setup/gbp2gdr b/tests/setup/gbp2gdr
index 7608a12..2dbb515 100755
--- a/tests/setup/gbp2gdr
+++ b/tests/setup/gbp2gdr
@@ -63,9 +63,8 @@ gbp import-orig --upstream-version=2.0 ../$ust
not-gdr-processable
-dch -v 2.0-1 -m 'new upstream (did gbp import-orig)'
-dch -r sid
-git commit -m changelog debian/changelog
+t-dch-commit -v 2.0-1 -m 'new upstream (did gbp import-orig)'
+t-dch-commit -r sid
t-archive-none $p
t-git-none
diff --git a/tests/tests/gdr-edits b/tests/tests/gdr-edits
index 30786fe..3efd063 100755
--- a/tests/tests/gdr-edits
+++ b/tests/tests/gdr-edits
@@ -9,8 +9,7 @@ t-setup-import gbp2gdr
cd $p
v=2.0-3
-dch -v $v -m testing
-git commit -m changelog debian/changelog
+t-dch-commit -v $v -m testing
t-git-debrebase analyse |tee ../anal.1
cat ../anal.1
@@ -28,8 +27,7 @@ for f in debian/zorkmid src.c; do
done
git commit -m 'MIXED add boths'
-dch -r sid
-git commit -m changelog debian/changelog
+t-dch-commit -r sid
git tag t.before