summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b2c520f..68fb46e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (3.10~) unstable; urgency=medium
Bugfixes:
* dgit: Copy several user.* settings from main tree git local config
to dgit private workarea. Closes:#853085.
+ * dgit: Strip initial newline from Changes line from dpkg-parsechangelog
+ so as to avoid blank line in commit messages. Closes:#853093.
Test suite:
* quilt-useremail: New test for user config copying (#853085).
diff --git a/dgit b/dgit
index 7ffbb89..9e60cda 100755
--- a/dgit
+++ b/dgit
@@ -2317,6 +2317,7 @@ sub generate_commits_from_dsc () {
my $authline = clogp_authline $clogp;
my $changes = getfield $clogp, 'Changes';
+ $changes =~ s/^\n//; # Changes: \n
my $cversion = getfield $clogp, 'Version';
if (@tartrees) {