summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 942c77b..05f08e7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (3.11~) unstable; urgency=medium
* dgit: fix rpush+buildinfo: Transfer buildinfos for signing.
Closes:#867693.
+ * dgit: Cope if the archive server sends an HTTP redirect,
+ by passing -L to curl. Closes:#867185,#867309.
--
diff --git a/dgit b/dgit
index 8d7af11..2685b6c 100755
--- a/dgit
+++ b/dgit
@@ -100,7 +100,7 @@ our $rewritemap = 'dgit-rewrite/map';
our (@git) = qw(git);
our (@dget) = qw(dget);
-our (@curl) = qw(curl);
+our (@curl) = qw(curl --proto-redir -all,http,https -L);
our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
our (@gpg) = qw(gpg);