summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Dgit.pm2
-rw-r--r--debian/changelog1
2 files changed, 2 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index 9216dee..a453f35 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -96,7 +96,7 @@ sub shellquote {
local $_;
foreach my $a (@_) {
$_ = $a;
- if (!length || m{[^-=_./0-9a-z]}i) {
+ if (!length || m{[^-=_./:0-9a-z]}i) {
s{['\\]}{'\\$&'}g;
push @out, "'$_'";
} else {
diff --git a/debian/changelog b/debian/changelog
index 43de16c..089e2a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -34,6 +34,7 @@ dgit (1.1~~) unstable; urgency=low
* When source package contains things called .git (even files, and even
in subdirectories), remove them. Closes:#793671.
* Introduce more sophisticated protocol negotiation for rpush.
+ * Do not quote `:' in shellquote.
--