summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index cbc2dd4..d3b225e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ dgit (0.13) unstable; urgency=low
Closes: #720958.
* Fix some bugs in dgit fetch --dry-run which made dgit push
--dry-run often not work at all.
+ * Update the local tracking branch for the dgit remote, when pushing.
+ Closes: #720956.
--
diff --git a/dgit b/dgit
index 0a599b0..353c2e5 100755
--- a/dgit
+++ b/dgit
@@ -911,6 +911,7 @@ sub dopush () {
create_remote_git_repo();
}
runcmd_ordryrun @git, qw(push),access_giturl(),"HEAD:".rrref();
+ runcmd_ordryrun @git, qw(update-ref -m), 'dgit push', lrref(), 'HEAD';
if (!$dryrun) {
rename "../$dscfn.tmp","../$dscfn" or die "$dscfn $!";
} else {