summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdgit2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 73763bc..1c2ca2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (0.20) unstable; urgency=high
+
+ * Use newest (not oldest) version currently in suite when calculating
+ what value to use for -v<version> by default. Closes:#732781.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 21 Dec 2013 19:13:56 +0000
+
dgit (0.19) unstable; urgency=low
Testing facilities:
diff --git a/dgit b/dgit
index 9b895b0..61af3b8 100755
--- a/dgit
+++ b/dgit
@@ -1803,7 +1803,7 @@ sub changesopts () {
my @vsns = archive_query('archive_query');
if (@vsns) {
@vsns = map { $_->[0] } @vsns;
- @vsns = sort { version_compare_string($a, $b) } @vsns;
+ @vsns = sort { -version_compare_string($a, $b) } @vsns;
$changes_since_version = $vsns[0];
progress "changelog will contain changes since $vsns[0]";
} else {