summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--tests/lib16
2 files changed, 9 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index f5078be..7f0c1ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (5.9+exp4~) experimental; urgency=medium
+
+ * test suite: tar up the artifacts, and name the tarball after
+ the test (to work around #903696).
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 13 Jul 2018 11:38:25 +0100
+
dgit (5.9+exp3) experimental; urgency=medium
* test suite: chmod a+r $AUTOPKGTEST explicitly.
diff --git a/tests/lib b/tests/lib
index 4425bf6..40f1f09 100644
--- a/tests/lib
+++ b/tests/lib
@@ -420,20 +420,8 @@ t-save-artifacts () {
if [ x"$artifacts" = x ]; then return; fi
if [ x"tmp" = x ]; then return; fi
: '(((((((((( t-save-artifacts ))))))))))'
- cp -dR --preserve=links,timestamps "$tmp"/. "$artifacts"/.
- chmod -R a+r -- "$artifacts"/.
- cd "$artifacts"/.
- find . \( -name \*.tar -o -name \*.sample \) -print0 | \
- xargs -0r rm -v
- find . \( -name .git \
- -o -path ./salsa/\* \
- -o -path ./git/\*.git \
- \) -type d \
- \! -path '*/.git/*/.git' -exec sh -xec '
- cd "$1"
- "$2"/playtree-save-refs
- git gc --prune=all
- ' x '{}' "$troot" \;
+ GZIP=-1v tar -C "$tmp" -zc -f "$artifacts/${0##*/}.tar.gz" \
+ --exclude=\*.tar .
: ')))))))))) t-save-artifacts ))))))))))'
}