summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8711080..29ff56e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
dgit (6.9~) unstable; urgency=medium
- *
+ * dgit: do not crash on push of a new gdr package. Closes:#906784.
--
diff --git a/dgit b/dgit
index e752108..f06087d 100755
--- a/dgit
+++ b/dgit
@@ -311,7 +311,7 @@ sub branch_is_gdr_unstitched_ff ($$$) {
my ($symref, $head, $ancestor) = @_;
my ($ffq_prev, $gdrlast) = branch_gdr_info($symref, $head);
return 0 unless $ffq_prev;
- return 0 unless is_fast_fwd $ancestor, $ffq_prev;
+ return 0 unless !defined $ancestor or is_fast_fwd $ancestor, $ffq_prev;
return 1;
}