summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit3
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d210d0..54583cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -76,6 +76,7 @@ dgit (1.5~~) unstable; urgency=medium
of .orig components the same way as their tarballs.
* Tidy up refs/dgit-fetch/ after dgit fetch (if successful).
* Fix handling of in-archive copies.
+ * Don't break if user has push.followTags=true. Closes:#827878.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 150c115..a96f471 100755
--- a/dgit
+++ b/dgit
@@ -3221,7 +3221,8 @@ END
push @pushrefs, $forceflag."refs/tags/$tw->{Tag}";
}
- runcmd_ordryrun @git, qw(push),access_giturl(), @pushrefs;
+ runcmd_ordryrun @git,
+ qw(-c push.followTags=false push), access_giturl(), @pushrefs;
runcmd_ordryrun @git, qw(update-ref -m), 'dgit push', lrref(), $dgithead;
supplementary_message(<<'END');