summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/tests/downstream-gitless3
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b9ef0e..0fd00bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ dgit (3.6~) unstable; urgency=medium
Test suite:
* downstream-gitless: Test import of .dsc from unknown distro.
+ * downstream-gitless: Test import of .dsc with unsafe url.
--
diff --git a/tests/tests/downstream-gitless b/tests/tests/downstream-gitless
index c70c50f..6b2df1b 100755
--- a/tests/tests/downstream-gitless
+++ b/tests/tests/downstream-gitless
@@ -77,6 +77,9 @@ t-dgit clone example avon example.avon
perl -i -pe 's/ test-dummy / unknown-distro / if m/^Dgit:/' $dscf
cd $p.import
+t-expect-fail 'hinted url with protocol file which is unsafe' \
+t-dgit import-dsc $dscf xunk
+
t-git-config dgit.dsc-url-proto-ok.file true
t-dgit import-dsc $dscf xunk