summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdgit2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index dc1f1d3..eef1f78 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (0.18.1) unstable; urgency=low
+
+ Bugfixes:
+ * sshpsql archive query method passes LANG=C. Closes:#729788.
+
+ --
+
dgit (0.18) unstable; urgency=low
Major new feature:
diff --git a/dgit b/dgit
index 2a5e26b..088f5d2 100755
--- a/dgit
+++ b/dgit
@@ -655,7 +655,7 @@ sub sshpsql ($$) {
my ($userhost,$dbname) = ($`,$'); #';
my @rows;
my @cmd = (access_cfg_ssh, $userhost,
- shellquote qw(psql -A), $dbname, qw(-c), $sql);
+ "export LANG=C; ".shellquote qw(psql -A), $dbname, qw(-c), $sql);
printcmd(\*DEBUG,$debugprefix."|",@cmd) if $debug>0;
open P, "-|", @cmd or die $!;
while (<P>) {