summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit19
-rw-r--r--dgit.13
3 files changed, 10 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index b02081e..331a316 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,8 @@ dgit (1.5~~) unstable; urgency=medium
* Introduce --rm-old-changes to delete previous builds' changes files.
* Remove any pre-existing _source.changes file before building source,
as a safety check.
+ * No longer tolerate a multitude of .changes files when doing push.
+ Instead, insist on a single one.
Documentation:
* Document the dgit-distro.DISTRO.quilt-mode config setting.
diff --git a/dgit b/dgit
index 9803b13..e59060d 100755
--- a/dgit
+++ b/dgit
@@ -2003,18 +2003,13 @@ END
}
my $head = git_rev_parse('HEAD');
if (!$changesfile) {
- my $multi = "$buildproductsdir/".changespat $cversion,'multi';
- if (stat_exists "$multi") {
- $changesfile = $multi;
- } else {
- my $pat = changespat $cversion;
- my @cs = glob "$buildproductsdir/$pat";
- fail "failed to find unique changes file".
- " (looked for $pat in $buildproductsdir, or $multi);".
- " perhaps you need to use dgit -C"
- unless @cs==1;
- ($changesfile) = @cs;
- }
+ my $pat = changespat $cversion;
+ my @cs = glob "$buildproductsdir/$pat";
+ fail "failed to find unique changes file".
+ " (looked for $pat in $buildproductsdir);".
+ " perhaps you need to use dgit -C"
+ unless @cs==1;
+ ($changesfile) = @cs;
} else {
$changesfile = "$buildproductsdir/$changesfile";
}
diff --git a/dgit.1 b/dgit.1
index d3f3702..588aac6 100644
--- a/dgit.1
+++ b/dgit.1
@@ -514,8 +514,7 @@ How to set this up is not yet documented.
.BI -C changesfile
Specifies the .changes file which is to be uploaded. By default
dgit push looks for single .changes file in the parent directory whose
-filename suggests it is for the right package and version - or,
-if there is a _multi.changes file, dgit uses that.
+filename suggests it is for the right package and version.
If the specified
.I changesfile