summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdgit3
1 files changed, 1 insertions, 2 deletions
diff --git a/dgit b/dgit
index f0a1e76..dd052fe 100755
--- a/dgit
+++ b/dgit
@@ -5815,8 +5815,6 @@ sub quiltify ($$$$) {
runcmd @git, qw(checkout -q), $cc, qw(debian/changelog);
}
-
- runcmd @git, qw(checkout -q master);
}
sub build_maybe_quilt_fixup () {
@@ -6303,6 +6301,7 @@ END
progress f_ "starting quiltify (multiple patches, %s mode)", $quilt_mode;
quiltify($clogp,$headref,$oldtiptree,\@failsuggestion);
+ runcmd @git, qw(checkout -q master);
if (!open P, '>>', ".pc/applied-patches") {
$!==&ENOENT or confess "$!";