summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b6c60f7..b0fbb92 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ dgit (4.5~) unstable; urgency=medium
* When checking that the tree is clean, check the git index too.
* In quilt_fixup_multipatch, work around git checkout paths
not deleting files. (Hypothetical bug AFAIAA.)
+ * Respect --quilt=nofix even if single-debian-patch.
Minor fixes:
* "confess" when we die due to a warning, rather than symply dieing.
diff --git a/dgit b/dgit
index b43308d..2a581f3 100755
--- a/dgit
+++ b/dgit
@@ -3727,6 +3727,7 @@ sub commit_quilty_patch () {
progress "nothing quilty to commit, ok.";
return;
}
+ quiltify_nofix_bail "", " (wanted to commit patch update)";
my @adds = map { s/[][*?\\]/\\$&/g; $_; } sort keys %adds;
runcmd_ordryrun_local @git, qw(add -f), @adds;
commit_admin <<END