summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtests/run-all10
1 files changed, 7 insertions, 3 deletions
diff --git a/tests/run-all b/tests/run-all
index b5c5bb0..c6df386 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
set -e
# convenience script for running the tests outside adt-run
# usage: tests/using-intree tests/run-all
+set -o pipefail
+
set +e
jcpus=`perl -MSys::CPU -we 'printf "-j%d\n",Sys::CPU::cpu_count()'`
set -e
@@ -11,5 +13,7 @@ if [ $# != 0 ]; then
set TESTSCRIPTS="$*"
fi
-set -x
-exec make $jcpus -k -f tests/Makefile "$@"
+(
+ set -x
+ exec make $jcpus -k -f tests/Makefile "$@"
+) 2>&1 |tee tests/tmp/run-all.log