summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--TODO.BRANCH35
-rw-r--r--debian/tests/control7
-rwxr-xr-xtests/tests/inarchivecopy4
3 files changed, 2 insertions, 44 deletions
diff --git a/TODO.BRANCH b/TODO.BRANCH
index 69efcae..c32550d 100644
--- a/TODO.BRANCH
+++ b/TODO.BRANCH
@@ -29,41 +29,6 @@ Test that, where appropriate, maint view tags are pushed to dgit git repo
* Test all three new --quilt=unapplied|gbp|dpm
-
- * IN ARCHIVE COPY Consider and implement fast-forward fixup
-
- - On fetch, check if specified git hash is ff from
- existing dgit branch, the same way we do for constructed
- dscs. The .dsc tells us the git tree but not necessarily
- the git hash.
-
- ...ERR MAYBE...
-
- complicated there are many branches
- dgit-repos: refs/dgit/suite
- archive dsc
- local; remotes/dgit/dgit/suite
- must be ff
- may contain dscs
- local: dgit/suite (not relevant to fetch)
-
- archive dsc must always be regarded
- as ff from (or same as) dgit-repos
- err depending on version number ?
-
- this code is what needs changing
- } else {
- fail "git head (".lrref()."=$lastpush_hash) is not a ".
- "descendant of archive's .dsc hash ($dsc_hash)";
- }
- it just needs to generate the fake merge and set $hash
- the archive skew stuff is all fine with this
-
- xxx actually, no, we need to stop from squashing our
- lrref with + updates
-
* Mention in-archive copy fix in debian/changelog
- * Add in-archive-move test case
-
* Remove lrfetchrefs at end of fetch_from_archive, for tidyness
diff --git a/debian/tests/control b/debian/tests/control
index 6e8287c..899bbb1 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -12,16 +12,11 @@ Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts
Restrictions: x-dgit-intree-only x-dgit-git-only
-Tests: inarchivecopy
-Tests-Directory: tests/tests
-Depends: dgit, dgit-infrastructure, devscripts
-Restrictions: x-dgit-unfinished
-
Tests: mirror mirror-debnewgit mirror-private
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, rsync
-Tests: build-modes build-modes-asplit build-modes-gbp-asplit clone-gitnosuite clone-nogit debpolicy-dbretry debpolicy-newreject distropatches-reject drs-clone-nogit drs-push-masterupdate drs-push-rejects dsd-clone-nogit dsd-divert fetch-localgitonly fetch-somegit-notlast newtag-clone-nogit oldtag-clone-nogit push-buildproductsdir push-newpackage push-nextdgit quilt quilt-gbp quilt-singlepatch rpush tag-updates test-list-uptodate trustingpolicy-replay
+Tests: build-modes build-modes-asplit build-modes-gbp-asplit clone-gitnosuite clone-nogit debpolicy-dbretry debpolicy-newreject distropatches-reject drs-clone-nogit drs-push-masterupdate drs-push-rejects dsd-clone-nogit dsd-divert fetch-localgitonly fetch-somegit-notlast inarchivecopy newtag-clone-nogit oldtag-clone-nogit push-buildproductsdir push-newpackage push-nextdgit quilt quilt-gbp quilt-singlepatch rpush tag-updates test-list-uptodate trustingpolicy-replay
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts
diff --git a/tests/tests/inarchivecopy b/tests/tests/inarchivecopy
index fbd197d..41c0321 100755
--- a/tests/tests/inarchivecopy
+++ b/tests/tests/inarchivecopy
@@ -2,8 +2,6 @@
set -e
. tests/lib
-t-restrict x-dgit-unfinished
-
t-setup-import examplegit
cd $p
@@ -59,4 +57,4 @@ copy-check 2.0
copy-check 2.1
-xxx rest of test
+echo ok.