summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6fcc9bd..27347d9 100644
--- a/Makefile
+++ b/Makefile
@@ -46,9 +46,9 @@ INFRA_PERLMODULES= \
Debian/Dgit/Infra.pm \
Debian/Dgit/Policy/Debian.pm
-all:
+all: $(MAN7PAGES)
-install: installdirs
+install: installdirs $(MAN7PAGES)
$(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
$(INSTALL_DATA) $(MAN1PAGES) $(DESTDIR)$(man1dir)
$(INSTALL_DATA) $(MAN7PAGES) $(DESTDIR)$(man7dir)
@@ -80,3 +80,11 @@ check installcheck:
clean distclean mostlyclean maintainer-clean:
rm -rf tests/tmp
+ set -e; for m in $(MAN7PAGES); do \
+ test -e $$m.pod && rm -f $$m; \
+ done
+
+%.7: %.7.pod
+ pod2man --section=7 --date="Debian Project" --center="dgit" \
+ --name=$(subst .7,,$@) \
+ $^ $@