summaryrefslogtreecommitdiff
path: root/README.git-debrebase
diff options
context:
space:
mode:
Diffstat (limited to 'README.git-debrebase')
-rw-r--r--README.git-debrebase32
1 files changed, 0 insertions, 32 deletions
diff --git a/README.git-debrebase b/README.git-debrebase
index 49fae98..e69de29 100644
--- a/README.git-debrebase
+++ b/README.git-debrebase
@@ -1,32 +0,0 @@
-
-
-So it would be possible to write a `git-debrebase' tool which would
-take (for example) B4, above, and be able to perform functions like:
-
- * Strip pseudomerges: Rewrite the current branch so it contains no
- pseudomerges, turning ...B3 into ...@-A-1-2-B3. (This should
- make a note, in your .git/ somewhere, of the original branch
- tip so that it can be overwritten with a pseudomerge.)
-
- * Cleanup branch: Reorganise the current branch so that the debian/
- changes come first, turning -@-A-1-2-B3 into ...@-A-B-1-2-3.
-
- * New upstream rebase: Start rebasing onto a new upstream version,
- turning ...#..@-A-B-1-2-3 into (...#..@-A-B-|...#'-)@'-1-2. This
- would be a wrapper around git-rebase, which prepares @' and then
- tries to rebase 1 2 onto @'. So if you ask for an interactive
- rebase @' doesn't appear in your commit list.
-
- Note that the construction of @' cannot fail because @' simply
- copies debian/ from B and and everything else from #'. (Rebasing A
- and B is undesirable. We want the debian/ files to be non-rebasing
- so we can `git log' and get the packaging history.)
-
- * Record pseudomerge. This is like "committing" your patch queue.
- The LH parent is taken from the previously recorded tip. (We could
- perhaps check that this is consistent with what we see in
- debian/changelog, but that is not a sufficient check so the
- recorded tip check is primary.)
-
-Maybe some of these operations should automatically edit
-debian/changelog.