summaryrefslogtreecommitdiff
path: root/TODO.BRANCH
diff options
context:
space:
mode:
Diffstat (limited to 'TODO.BRANCH')
-rw-r--r--TODO.BRANCH54
1 files changed, 49 insertions, 5 deletions
diff --git a/TODO.BRANCH b/TODO.BRANCH
index b526d21..0b28a74 100644
--- a/TODO.BRANCH
+++ b/TODO.BRANCH
@@ -1,4 +1,3 @@
-
Tag rename unfinished business
(things resulting from searching for `tag' where searching for
`debiantag' wouldn't find them)
@@ -16,6 +15,9 @@ Tag rename unfinished business
- in dopush (?), we need to sort out synthetic fast forard
this should not depend entirely on quilt mode
but will always be needed if quiltmode_splitbrain
+ * On push, if ff fixup mode enabled, check debian/changelog,
+ and maybe make fake merge, maybe in dgit view, maybe
+ elsewhere ?
- there is some confusion between $split_brain (did we actually
generate any commits) and quiltmode_splitbrain (might we have done,
@@ -29,9 +31,51 @@ Want tests for
old tag
- rejecting push of same version with one tag when then the other
-That, where appropriate, maint view tags are pushed to dgit git repo
+Test that, where appropriate, maint view tags are pushed to dgit git repo
+
+
+ * Provide --gpbpq[=:] options
+
+ * Document --quilt=unapplied|gbp|dpm
+
+ * Mention new --quilt=* in debian/changelog
+
+ * Mention in-archive copy fix in debian/changelog
+
+ * Test --quilt=*
+
+
+ * IN ARCHIVE COPY Consider and implement fast-forward fixup
+
+ - On fetch, check if specified git hash is ff from
+ existing dgit branch, the same way we do for constructed
+ dscs. The .dsc tells us the git tree but not necessarily
+ the git hash.
+
+ ...ERR MAYBE...
+
+ complicated there are many branches
+ dgit-repos: refs/dgit/suite
+ archive dsc
+ local; remotes/dgit/dgit/suite
+ must be ff
+ may contain dscs
+ local: dgit/suite (not relevant to fetch)
+
+ archive dsc must always be regarded
+ as ff from (or same as) dgit-repos
+ err depending on version number ?
+
+ this code is what needs changing
+ } else {
+ fail "git head (".lrref()."=$lastpush_hash) is not a ".
+ "descendant of archive's .dsc hash ($dsc_hash)";
+ }
+ it just needs to generate the fake merge and set $hash
+ the archive skew stuff is all fine with this
+
+ xxx actually, no, we need to stop from squashing our
+ lrref with + updates
-----------
+ * Add in-archive-move test case
-Provide --gpbpq[=:] options
-Document --quilt=unapplied|gbp|dpm