summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index baff8f8..614fb7a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,10 +30,16 @@ override_dh_gencontrol:
v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
+override_dh_auto_clean:
+ dh_auto_clean
+ make -C po clean
+
globalperl=/usr/share/perl5
override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
+ make -C po install prefix=/usr DESTDIR=../debian/tmp \
+ SUPPRESS_PO_UPDATE=1 S=''
specpkg_install_gdr: p=git-debrebase
specpkg_install_gdr: pm=GDR