summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog73
1 files changed, 42 insertions, 31 deletions
diff --git a/debian/changelog b/debian/changelog
index bd5ab63..6ef374b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,32 @@
dgit (1.1~~) unstable; urgency=low
- * Fix Vcs-Git and Vcs-Browse to refer to chiark. (The dgit-repos on
- alioth aren't suitable right now because the master there can
- currently only be updated with an actual upload, ie dgit push.)
+ Bugfixes:
+ * When source package contains things called .git (even files, and even
+ in subdirectories), remove them. Closes:#793671.
+ * Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
+ before the actual header, so dgit works with https_proxy set (!)
+ * --new is needed for read access to packages in NEW, too. Document
+ this, and make it work properly.
+ * Work around #793471 (madness with $SIG{__WARN__} and Perl's system
+ builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
+ check getppid.
+
+ Configurability:
+ * Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD. Closes:#793427.
+ * Make configuration able to prevent dpkg-mergechangelogs setup.
+ * Provide dgit setup-new-tree (like dpkg-setup-mergechangelogs
+ but only does it if not disabled in config).
+ * Set up git user.email and user.name from distro access config
+ or DEBEMAIL/DEBFULLNAME. Closes:#793410.
+ * When key to use not specified any other way, use the debian/changelog
+ trailer line. Closes:#793423.
+ * Honour --git= (mostly).
+
+ Documentation:
* Fix some manpage typos. [ Richard Hartmann ]
* Manpage said that --clean=check was -wn but that is --clean=none;
correctly document that --clean=check is actually -wc.
- * Document that up to -DDD (not just -DD) is meaningfully different.
+ * Document that up to -DDDD (not just -DD) is meaningfully different.
* Document that -cname=value applies only for this run.
* Improve manpage comment about defining a new distro.
* Document that --quilt=linear is the default for Debian.
@@ -21,38 +41,13 @@ dgit (1.1~~) unstable; urgency=low
* Manpage: Clarify wording of readonly config.
* Manpage: Better cross-references for -k and keyid.
* dgit(7): No longer say that dgit-repos lives on Alioth.
- * Infrastructure: Get mirroring right for fresh repos of existing
- packages (!)
- * --new is needed for read access to packages in NEW, too. Document
- this, and make it work properly.
- * Work around #793471 (madness with $SIG{__WARN__} and Perl's system
- builtin): move $SIG{} setting into setup_sigwarn in Dgit.pm, and
- check getppid.
- * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
- (using setup_sigwarn).
- * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
- * When source package contains things called .git (even files, and even
- in subdirectories), remove them. Closes:#793671.
+
+ Improvements:
* Introduce more sophisticated protocol negotiation for rpush.
* Do not quote `:' in shellquote.
- * Test suite: Honour DGIT_TEST_DEBUG=''.
* Print a supplementary message when push fails, giving advice to
the user about how to retry. Closes:#793144.
- * Honour dgit-distros.DISTRO.cmd-CMD and .opts-CMD. Closes:#793427.
* Slurp in entire git config, for better performance.
- * With -DDDD, print out all gitcfg references (copious!)
- * Fix a debug message in the obsolete sshpsql archive access driver.
- * Make configuration able to prevent dpkg-mergechangelogs setup.
- * Provide dgit setup-new-tree (like dpkg-setup-mergechangelogs
- but only does it if not disabled in config).
- * Set up git user.email and user.name from distro access config
- or DEBEMAIL/DEBFULLNAME. Closes:#793410.
- * Work around curl -sS -I printing `HTTP/1.0 200 Connection established'
- before the actual header, so dgit works with https_proxy set (!)
- * When key to use not specified any other way, use the debian/changelog
- trailer line. Closes:#793423.
- * Honour --git= (mostly).
- * Test suite: More automatic enumeration of tests.
* Rename `git-build' operation to `gbp-build' to make it clearer what
it's for. Keep the old name as an alias.
* Show `dgit sbuild' in usage message.
@@ -63,6 +58,22 @@ dgit (1.1~~) unstable; urgency=low
pass -nc.
* Also suppress spurious runs of the clean target when building using
git-buildpackage.
+
+ Infrastructure:
+ * Infrastructure: Get mirroring right for fresh repos of existing
+ packages (!)
+
+ Packaging, cleanups, debugging and test suite:
+ * Fix Vcs-Git and Vcs-Browse to refer to chiark. (The dgit-repos on
+ alioth aren't suitable right now because the master there can
+ currently only be updated with an actual upload, ie dgit push.)
+ * Make warnings fatal in dpkg-repos-admin-debian, dgit-ssh-dispatch
+ (using setup_sigwarn).
+ * Make warnings fatal in tstunt/dpkg-parsechangelog (directly).
+ * Test suite: Honour DGIT_TEST_DEBUG=''.
+ * With -DDDD, print out all gitcfg references (copious!)
+ * Fix a debug message in the obsolete sshpsql archive access driver.
+ * Test suite: More automatic enumeration of tests.
* Test suite: Provide tests which check that all our various build
operations run the right targets as expected (ie, that we are massaging
the arguments to dpkg-buildpackage, and suppressing our clean target,