summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index da482ed..8beb109 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,10 +51,14 @@ specpkg_install_gdr: pm=GDR
specpkg_install_infra: p=dgit-infrastructure
specpkg_install_infra: pm=Infra
+define specpkg_install_common
+ make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+endef
+
specpkg_install_%: tok=$*
specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
specpkg_install_%:
- make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+ $(specpkg_install_common)
# # Most of the Perl modules in this package live in
# # $(specperl). The exception is Debian::Dgit::Infra, which
# # lives in $(globalperl) and adds $(specperl) to @INC.