summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog101
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules30
-rw-r--r--debian/tests/control13
-rw-r--r--debian/tests/control.in2
5 files changed, 143 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 507d29f..a67e8db 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,104 @@
+dgit (5.2) unstable; urgency=medium
+
+ dgit bugfixes:
+ * When all Debian changes vanish with single-debian-patch,
+ do not fail to commit the patch queue removal. Closes:#877036.
+ * When build fails because the network is offline, mention
+ that this is because --since-version was not specified.
+ Closes:#883340.
+ * When quilt fixup fails because of discrepancies, print a
+ git diff rune which will show them. Closes:#865446.
+ * When fetch or push wants git fetch (other than in a situation where it
+ happes to be a noop) but --dry-run was specified, fail with an
+ explanation, rather than looping with a false coplaint about git
+ fetch. Closes:#871317.
+ * --overwrite now no longer crashes if there is nothing to overwrite
+ (eg, when used with --new). Instead, it is simply ignored, as it is
+ ignored in situations where the push is fast forward. Closes:#863576.
+
+ dgit/git-debrebase interop bugfixes:
+ * git-debrebase interop: Add a missing debugcmd debugging print.
+ * git-debrebase interop: Actually tolerate git-debrebase make-patches
+ exiting with status 7.
+
+ dgit vcs-git handling improvements:
+ * Provide `update-vcs-git' subcommand, for creating and adjusting the
+ vcs-git remote url. Useful for transition from alioth to salsa.
+ Closes:#902006.
+ * Print a warning to stderr on `dgit fetch sid', if your vcs-git
+ remote url disagrees with what's in sid's .dsc.
+
+ documentation:
+ * dgit(1): Mention under `dgit build' that it uses the network.
+ * dgit(1): Clarify that --overwrite does nothing if not needed.
+ Closes:#863578.
+ * dgit-user(7): Recommend sbuild-debian-developer-setup.
+ [ Sean Whitton. ] Closes:895779.
+
+ test suite:
+ * Use nproc(1) rather than Sys::CPU. This is more portable and does not
+ depend on libsys-cpu-perl being installed. Closes:888496.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 24 Jun 2018 23:33:28 +0100
+
+dgit (5.1) unstable; urgency=medium
+
+ dgit gitattributes handling:
+ * Squash the working-tree-encoding attribute too.
+ * Update an existing `dgit-defuse-attrs' macro in .git/info/attributes.
+ * Test the working-tree-encoding attribute squashing properly.
+ Closes:#901900.
+
+ git-debrebase fixes:
+ * new-upstream: fix (this time for sure) ff check handling
+ of multi-piece upstreams.
+ * Suppress gbp pq export output, except in case of error.
+ Closes:#901809.
+ * Manpages: Fix typos and etc.
+ * Fix a typo in the package description.
+
+ Test suite:
+ * Triger ci.debian.net autopkgtests on: gnupg diffutils patch.
+ (A dummy test is used to add to Testsuite-Triggers.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 20 Jun 2018 23:20:57 +0100
+
+dgit (5.0) unstable; urgency=low
+
+ Major new facility:
+ * git-debrebase, a new git workflow tool, in its own package.
+ * dgit will now, when appropriate, check if it should call
+ git-debrebase.
+
+ [ Thanks to Sean Whitton for much useful input, and for
+ dgit-maint-debrebase(7). ]
+
+ dgit bugfixes:
+ * Fix the exit status of programs in dgit.deb, to avoid the Perl
+ misfeature which sometimes copies $! to the exit status.
+ * When checking that the tree is clean, check the git index too.
+ * In quilt_fixup_multipatch, work around git checkout paths
+ not deleting files. (Hypothetical bug AFAIAA.)
+ * Respect --quilt=nofix even if single-debian-patch.
+
+ dgit minor fixes:
+ * "confess" when we die due to a warning, rather than symply dieing.
+
+ Internal changes:
+ * Move $playground global to dgit.
+ * Break git_get_symref and $extra_orig_namepart_re out into Dgit.pm.
+ * Changes to support git-debrebase.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 18 Jun 2018 00:29:44 +0100
+
+dgit (4.4) unstable; urgency=high
+
+ Test suite bugfix:
+ * Use full key hash rather than short keyid. Closes:#896653.
+ [ report: Paul Gevers; fix: Chris Lamb ]
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 23 Apr 2018 13:18:51 +0100
+
dgit (4.3~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
diff --git a/debian/control b/debian/control
index 4405e14..42f68f6 100644
--- a/debian/control
+++ b/debian/control
@@ -26,6 +26,15 @@ Description: git interoperability with the Debian archive
.
dgit clone and dgit fetch construct git commits from uploads.
+Package: git-debrebase
+Depends: perl, git-core, libdpkg-perl, libfile-fnmatch-perl
+ ${misc:Depends}
+Recommends: dgit, git-buildpackage
+Architecture: all
+Description: rebasing git workflow tool for Debian packaging
+ git-debrebase is a tool for representing in git, and manipulating,
+ Debian packages based on upstream source code.
+
Package: dgit-infrastructure
Depends: ${misc:Depends}, perl, git-core, gpgv, chiark-utils-bin,
libjson-perl, libdigest-sha-perl, libdbd-sqlite3-perl, sqlite3,
diff --git a/debian/rules b/debian/rules
index 9249f88..baff8f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,25 +31,33 @@ override_dh_gencontrol:
perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
globalperl=/usr/share/perl5
-infraperl=/usr/share/dgit/infra/perl5
-override_dh_auto_install:
+override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
- make install-infra prefix=/usr DESTDIR=debian/dgit-infrastructure \
- perldir=$(infraperl)
-# # Most of the Perl modules in dgit-infrastructure live in
-# # $(infraperl). The exception is Debian::Dgit::Infra, which
-# # lives in $(globalperl) and adds $(infraperl) to @INC.
+
+specpkg_install_gdr: p=git-debrebase
+specpkg_install_gdr: pm=GDR
+
+specpkg_install_infra: p=dgit-infrastructure
+specpkg_install_infra: pm=Infra
+
+specpkg_install_%: tok=$*
+specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
+specpkg_install_%:
+ make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
+# # Most of the Perl modules in this package live in
+# # $(specperl). The exception is Debian::Dgit::Infra, which
+# # lives in $(globalperl) and adds $(specperl) to @INC.
set -ex; \
- base=debian/dgit-infrastructure; \
- mod=Debian/Dgit/Infra.pm; \
- src=$${base}$(infraperl)/$${mod}; \
+ base=debian/$(p); \
+ mod=Debian/Dgit/$(pm).pm; \
+ src=$${base}$(specperl)/$${mod}; \
dst=$${base}$(globalperl)/$${mod}; \
mkdir -p $${dst%/*}; \
mv -f $$src $$dst; \
perl -i -p -e 'next unless m/###substituted###/;' \
-e 'next unless s/^# (?=unshift \@INC,)//;' \
- -e 'die unless s{q\{\S+\}}{q{$(infraperl)}};' \
+ -e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \
$$dst
debian/tests/control: tests/enumerate-tests debian/tests/control.in
diff --git a/debian/tests/control b/debian/tests/control
index f3d20f1..378cf4c 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -16,10 +16,23 @@ Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin
Restrictions: x-dgit-intree-only x-dgit-git-only
+Tests: gdr-diverge-nmu gdr-diverge-nmu-dgit gdr-edits gdr-import-dgit gdr-makepatches7 gdr-subcommands
+Tests-Directory: tests/tests
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, git-debrebase, git-buildpackage, faketime
+
+Tests: gdr-newupstream gdr-viagit
+Tests-Directory: tests/tests
+Depends: chiark-utils-bin, git-debrebase, git-buildpackage, faketime
+
Tests: gitattributes
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bsdgames, man-db, git-man
+Tests: hint-testsuite-triggers
+Tests-Directory: tests/tests
+Depends: gnupg, patch, diffutils
+Restrictions: hint-testsuite-triggers
+
Tests: defdistro-mirror mirror mirror-debnewgit mirror-private
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, rsync
diff --git a/debian/tests/control.in b/debian/tests/control.in
index 960d3ef..b558a25 100644
--- a/debian/tests/control.in
+++ b/debian/tests/control.in
@@ -1,2 +1,2 @@
Tests-Directory: tests/tests
-Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin
+Depends: