summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/tests/control2
4 files changed, 19 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 775be6c..6629b0b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -31,6 +31,10 @@ dgit (0.23~) unstable; urgency=low
* Add missing `gpgv' to test dependencies in debian/tests/control.
+ * New dgit-infrastructure binary package containing dgit-repos-server et
+ al. Client users probably don't want this stuff. Also, it provides a
+ convenient way to publish the dependencies.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/debian/control b/debian/control
index 798465b..cc26c04 100644
--- a/debian/control
+++ b/debian/control
@@ -21,3 +21,13 @@ Description: git interoperability with the Debian archive
dgit push constructs uploads from git commits
.
dgit clone and dgit fetch construct git commits from uploads.
+
+Package: dgit-infrastructure
+Depends: ${misc:Depends}
+Recommends: perl, git-core, gpgv, chiark-utils-bin, wget,
+ libdigest-sha-perl
+Architecture: all
+Priority: extra
+Description: dgit server backend infrastructure
+ This package contains tools which are useful for setting up a dgit
+ git repository server. You probably want dgit, the client package.
diff --git a/debian/rules b/debian/rules
index fece672..e02ea90 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,3 +29,7 @@ override_dh_gencontrol:
cd debian/dgit; \
v=$$(perl -ne 'print if s/^version:\s+//i' DEBIAN/control); \
perl -i -pe "s/UNRELEASED/$$v/g if m/###substituted###/" usr/bin/dgit
+
+override_dh_auto_install:
+ make install prefix=/usr DESTDIR=debian/dgit
+ make install-infra prefix=/usr DESTDIR=debian/dgit-infrastructure
diff --git a/debian/tests/control b/debian/tests/control
index aca24c4..37124e6 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,3 +1,3 @@
Tests: clone-nogit fetch-localgitonly fetch-somegit-notlast push-newpackage push-nextdgit quilt push-buildproductsdir
Tests-Directory: tests/tests
-Depends: @, devscripts, gpgv
+Depends: dgit, dgit-infrastructure, devscripts, gpgv