summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog72
-rw-r--r--debian/control4
-rw-r--r--debian/copyright3
-rw-r--r--debian/git-debpush.install1
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/tests/control8
6 files changed, 95 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b63611..40084ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,75 @@
+dgit (9.5) unstable; urgency=medium
+
+ git-debpush [Sean Whitton]:
+ * Support ignoring individual checks with --force=check. Closes:#932459.
+ * Check upstream source is identical in the upstream tag.
+ * Check that patches are (un)applicable. Closes:#932477.
+ * Check for an unstitched git-debrebase branch. Closes:#932612.
+ * Check for explicitly pushing detached HEAD.
+
+ dgit clone [Ian Jackson]:
+ * No longer create an "origin" remote. Closes:#932694.
+
+ Documentation:
+ * dgit-maint-bpo(7): new manpage for maintainers of official Debian
+ backports. Closes:#857490. [Sean Whitton]
+ * git-debrebase(1): make this manpage a less intimidating entry point.
+ Closes:#926656.
+ [Sean Whitton & Ian Jackson; prompted by feedback from Sam Hartman]
+
+ Miscellaneous:
+ * Correct the description of --force in git-debpush(1) [Sean Whitton].
+ * git-debrebase(*): fix some crossreferences [Sean Whitton].
+ Closes:#932536.
+ * Break out git-playtree-setup and rewrite in shell. [Ian Jackson]
+ * Fix organisation copyright attribution for Matthew Vernon's
+ contributions. Closes:#932630.
+ * HACKING: new document for helping people work on the code. [Ian Jackson]
+ * Update Vcs-Git etc. to point to salsa.
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Mon, 22 Jul 2019 21:38:19 +0100
+
+dgit (9.4) unstable; urgency=medium
+
+ dgit:
+ * Support the Ubuntu Cloud Archive [Matthew Vernon]. Closes:#932322.
+
+ test suite:
+ * tag-to-upload tests: Tolerate a changed git message. Closes:#932475.
+
+ administrivia:
+ * debian/copyright: Add some missing credtis
+ * Update copyright notices in many files
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 20 Jul 2019 16:26:32 +0100
+
+dgit (9.3) unstable; urgency=medium
+
+ dgit and git-debrebase bugfixes:
+ * No longer crash if .git/logs does not exist when we need it.
+ * Report the upstream tag, rather than commit id, in tags/commits,
+ if the user explicitly specifies refs/tags/...
+
+ tag-to-upload, git-debpush [Sean Whitton]:
+ * Several new checks designed to prevent broken uploads.
+ - Including: Check that upstream tag is ancestor of branch to be tagged.
+ Closes:#932096
+ * Cope with spaces in user-supplied upstream tag.
+
+ tag-to-upload, server side:
+ * Fix non-default quilt modes. These were all previously broken.
+ * Arrange to report the upstream tag in dgit-generated commits/tags.
+
+ dgit archive query improvements [Matthew Vernon]:
+ * dgit(1): document the presence of the aptget method. Closes:#932321.
+
+ minor supporting changes:
+ * New tests tagupl-baredebian and tagupl-gbp.
+ * Tiny addition to debugging output and test suite output.
+ * Test suite rearrangements.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 18 Jul 2019 03:10:25 +0100
+
dgit (9.2~bpo10+1) buster-backports; urgency=medium
* Rebuild for buster-backports.
diff --git a/debian/control b/debian/control
index 15c3cd4..3395984 100644
--- a/debian/control
+++ b/debian/control
@@ -5,8 +5,8 @@ Maintainer: Ian Jackson <ijackson@chiark.greenend.org.uk>
Standards-Version: 3.9.4.0
Build-Depends: debhelper (>= 9), gettext, po4a, tcl
Testsuite: autopkgtest
-Vcs-Git: git://git.chiark.greenend.org.uk/~ianmdlvl/dgit.git
-Vcs-Browser: http://www.chiark.greenend.org.uk/ucgi/~ianmdlvl/git/dgit.git/
+Vcs-Git: https://salsa.debian.org/dgit-team/dgit
+Vcs-Browser: https://salsa.debian.org/dgit-team/dgit
Package: dgit
Depends: perl, libwww-perl, libdpkg-perl, git-core, devscripts, dpkg-dev,
diff --git a/debian/copyright b/debian/copyright
index e4270c6..22c9713 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,6 +3,9 @@ Integration between git and Debian-style archives
Copyright (C)2013-2019 Ian Jackson
Copyright (C)2016-2019 Sean Whitton
+Copyright (C)2018-2019 Frans Spiesschaert
+Copyright (C)2019 Matthew Vernon / Genome Research Limited
+Copyright (C)2019 Paul Hardy
Copyright (C)1999-2010 Joey Hess
Copyright (C)2004-2010 Colin Watson
diff --git a/debian/git-debpush.install b/debian/git-debpush.install
new file mode 100644
index 0000000..afba498
--- /dev/null
+++ b/debian/git-debpush.install
@@ -0,0 +1 @@
+git-playtree-setup /usr/share/git-debpush
diff --git a/debian/rules b/debian/rules
index ea2ceac..4d1a760 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,8 @@
# dgit
# Integration between git and Debian-style archives
#
-# Copyright (C)2013-2016 Ian Jackson
+# Copyright (C)2013-2019 Ian Jackson
+# Copyright (C)2019 Sean Whitton
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -42,6 +43,7 @@ override_dh_auto_install: specpkg_install_gdp \
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
+ mv debian/dgit/usr/bin/git-playtree-setup debian/dgit/usr/share/dgit
make -C po4a install DESTDIR=../debian/tmp S=''
override_dh_missing:
@@ -63,6 +65,9 @@ specpkg_install_gdp: tok=gdp
specpkg_install_gdp: specperl=/usr/share/dgit/gdp/perl5
specpkg_install_gdp:
$(specpkg_install_common)
+ set -x; perl -i -pe 'next unless m/###substituted###/;' \
+ -e 's{^(git_playtree_setup)=.*}{$$1=/usr/share/$p/git-playtree-setup};' \
+ debian/$(p)/usr/bin/*
specpkg_install_%: tok=$*
specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
@@ -71,6 +76,8 @@ specpkg_install_%:
# # Most of the Perl modules in this package live in
# # $(specperl). The exception is Debian::Dgit::Infra, which
# # lives in $(globalperl) and adds $(specperl) to @INC.
+# # We also abuse this for git-playtree-setup. In .debs, this
+# # goes in the per-.deb @INC dir. See Dgit.pm::playtree_setup.
set -ex; \
base=debian/$(p); \
mod=Debian/Dgit/$(pm).pm; \
@@ -78,6 +85,7 @@ specpkg_install_%:
dst=$${base}$(globalperl)/$${mod}; \
mkdir -p $${dst%/*}; \
mv -f $$src $$dst; \
+ install -m 755 git-playtree-setup $${base}$(specperl); \
perl -i -p -e 'next unless m/###substituted###/;' \
-e 'next unless s/^# (?=unshift \@INC,)//;' \
-e 'die unless s{q\{\S+\}}{q{$(specperl)}};' \
diff --git a/debian/tests/control b/debian/tests/control
index 9bdce9d..63e9369 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -68,6 +68,14 @@ Tests: tagupl
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, libdpkg-perl, libgit-wrapper-perl, liblist-compare-perl, libstring-shellquote-perl, libtry-tiny-perl, git-debpush
+Tests: tagupl-baredebian
+Tests-Directory: tests/tests
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, quilt, git-debpush, git-debrebase, git-buildpackage, libdpkg-perl, libgit-wrapper-perl, liblist-compare-perl, libstring-shellquote-perl, libtry-tiny-perl
+
+Tests: tagupl-gbp
+Tests-Directory: tests/tests
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, git-debpush, libdpkg-perl, libgit-wrapper-perl, liblist-compare-perl, libstring-shellquote-perl, libtry-tiny-perl
+
Tests: tagupl-native
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, git-debpush