summaryrefslogtreecommitdiff
path: root/dgit-maint-merge.7.pod
diff options
context:
space:
mode:
Diffstat (limited to 'dgit-maint-merge.7.pod')
-rw-r--r--dgit-maint-merge.7.pod28
1 files changed, 5 insertions, 23 deletions
diff --git a/dgit-maint-merge.7.pod b/dgit-maint-merge.7.pod
index 245be4c..0d8b2da 100644
--- a/dgit-maint-merge.7.pod
+++ b/dgit-maint-merge.7.pod
@@ -34,20 +34,6 @@ that upstream makes available for download.
=back
-=head1 GIT CONFIGURATION
-
-Add the following to your ~/.gitconfig to teach git-archive(1) how to
-compress orig tarballs:
-
-=over 4
-
- [tar "tar.xz"]
- command = xz -c
- [tar "tar.gz"]
- command = gzip -c
-
-=back
-
=head1 INITIAL DEBIANISATION
This section explains how to start using this workflow with a new
@@ -94,16 +80,15 @@ unless you also happen to be involved in upstream development. We
work with upstream tags rather than any branches, except when
forwarding patches (see FORWARDING PATCHES UPSTREAM, below).
-Finally, you need an orig tarball. Generate one with git-archive(1):
+Finally, you need an orig tarball:
=over 4
- % git archive -o ../foo_1.2.2.orig.tar.xz 1.2.2
+ % git deborig
=back
-If you are using the version 1.0 source package format, replace 'xz'
-with 'gz'.
+See git-deborig(1) if this fails.
This tarball is ephemeral and easily regenerated, so we don't commit
it anywhere (e.g. with tools like pristine-tar(1)).
@@ -121,7 +106,7 @@ A convenient way to perform this check is to import the tarball as
described in the following section, using a different value for
'upstream-tag', and then use git-diff(1) to compare the imported
tarball to the release tag. If they are the same, you can use
-upstream's tarball instead of running git-archive(1).
+upstream's tarball instead of running git-deborig(1).
=back
@@ -313,18 +298,15 @@ Once you're satisfied with what will be merged, update your package:
=over 4
- % git archive -o ../foo_1.2.3.orig.tar.xz 1.2.3
% git merge 1.2.3
% dch -v1.2.3-1 New upstream release.
% git add debian/changelog && git commit -m changelog
+ % git deborig
=back
and you are ready to try a build.
-Again, if you are using the version 1.0 source package format, replace
-'xz' with 'gz'.
-
=head2 When upstream releases only tarballs
You will need the I<debian/gbp.conf> from "When upstream releases only