summaryrefslogtreecommitdiff
path: root/dgit.1
diff options
context:
space:
mode:
Diffstat (limited to 'dgit.1')
-rw-r--r--dgit.120
1 files changed, 20 insertions, 0 deletions
diff --git a/dgit.1 b/dgit.1
index 0d395ff..677a51b 100644
--- a/dgit.1
+++ b/dgit.1
@@ -73,6 +73,22 @@ for the distro to which
.I suite
belongs.
+.I suite
+may be
+.IR mainsuite \fB,\fR subsuite ...
+in which case dgit will synthesize a view giving the most
+recent version in any of the specified suites.
+(The subsuites do not need to have the package.)
+If a subsuite starts with
+.B -
+then mainsuite is prepended.
+Each of the suite names will be individually canonicalised
+to calculate the canonical branch names to use.
+When using this facility, it is important to always specify the
+same suites in the same order:
+dgit will not be make a coherent fast-forwarding history
+view otherwise.
+
For your convenience, the
.B vcs-git
remote will be set up from the package's Vcs-Git field, if there is
@@ -90,6 +106,10 @@ then dgit fetch defaults to
.IR suite ;
otherwise it parses debian/changelog and uses the suite specified
there.
+
+suite may be
+.IR mainsuite \fB,\fR subsuite ...
+as for clone.
.TP
\fBdgit pull\fR [\fIsuite\fP]
Does dgit fetch, and then merges the new head of the remote tracking