summaryrefslogtreecommitdiff
path: root/dgit.1
diff options
context:
space:
mode:
Diffstat (limited to 'dgit.1')
-rw-r--r--dgit.130
1 files changed, 26 insertions, 4 deletions
diff --git a/dgit.1 b/dgit.1
index c0c1450..e8f7eb2 100644
--- a/dgit.1
+++ b/dgit.1
@@ -200,16 +200,25 @@ public key in its keyring (but not your private key, obviously).
.TP
.B dgit setup-new-tree
Configure the current working tree the way that dgit clone would have
-set it up. Like running dgit setup-mergechangelogs (but only does it
-if dgit is configured to do it automatically).
+set it up. Like running
+.B dgit setup-useremail
+and
+.B setup-mergechangelogs
+(but only does each thing if dgit is configured to do it automatically).
+You can use these in any git repository, not just ones used with
+the other dgit operations.
+.TP
+.B dgit setup-useremail
+Set the working tree's user.name and user.email from the
+distro-specific dgit configuration
+.RB ( dgit-distro. \fIdistro\fR .user-name " and " .user-email ),
+or DEBFULLNAME or DEBEMAIL.
.TP
.B dgit setup-mergechangelogs
Configures a git merge helper for the file
.B debian/changelog
which uses
.BR dpkg-mergechangelogs .
-You can use this in any git repository, not just ones used with
-the other dgit operations.
.TP
.B dgit quilt-fixup
`3.0 (quilt)' format source packages need changes representing not
@@ -639,6 +648,15 @@ Not relevant for Debian.
.BI dgit-distro. distro .upload-host
Might be useful if you have an intermediate queue server.
.TP
+.BI dgit-distro. distro .user-name " " dgit-distro. distro .user-email
+Values to configure for user.name and user.email in new git trees. If
+not specified, the DEBFULLNAME and DEBEMAIL environment variables are
+used, respectively. Only used if .setup-usermail is not disabled.
+.TP
+.BI dgit-distro. distro .setup-useremail
+Whether to set user.name and user.email in new git trees.
+True by default. Ignored for dgit setup-setup-useremail, which does it anyway.
+.TP
.BI dgit-distro. distro .setup-mergechangelogs
Whether to setup a merge driver which uses dpkg-mergechangelogs for
debian/changelog. True by default. Ignored for dgit
@@ -718,6 +736,10 @@ interprets it the same way as git does.
See
also the --ssh= and --ssh: options.
.TP
+.BR DEBEMAIL ", " DEBFULLNAME
+Default git user.email and user.name for new trees. See
+.BR "dgit setup-new-tree" .
+.TP
.BR gpg ", " dpkg- "..., " debsign ", " git ", " curl ", " dput ", " LWP::UserAgent
and other subprograms and modules used by dgit are affected by various
environment variables. Consult the documentaton for those programs