summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit4
1 files changed, 4 insertions, 0 deletions
diff --git a/dgit b/dgit
index b136ed9..fcc792d 100755
--- a/dgit
+++ b/dgit
@@ -724,8 +724,12 @@ sub dopush () {
fail "looked for .dsc $dscfn, but $!;".
" maybe you forgot to build";
$dsc = parsecontrol("../$dscfn","$dscfn");
+ my $dscpackage = getfield $dsc, 'Source';
my $format = getfield $dsc, 'Format';
my $dversion = getfield $dsc, 'Version';
+ ($dscpackage eq $package && $dversion eq $cversion)
+ fail "$dsc is for $dscpackage $dversion".
+ " but debian/changelog is for $package $cversion";
print DEBUG "format $format\n";
if ($format eq '3.0 (quilt)') {
print "Format \`$format', urgh\n";