summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit6
1 files changed, 5 insertions, 1 deletions
diff --git a/dgit b/dgit
index bfc168c..db12d22 100755
--- a/dgit
+++ b/dgit
@@ -4597,11 +4597,15 @@ sub branchsuite () {
}
}
-sub fetchpullargs () {
+sub package_from_d_control () {
if (!defined $package) {
my $sourcep = parsecontrol('debian/control','debian/control');
$package = getfield $sourcep, 'Source';
}
+}
+
+sub fetchpullargs () {
+ package_from_d_control();
if (@ARGV==0) {
$isuite = branchsuite();
if (!$isuite) {