summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit362
1 files changed, 291 insertions, 71 deletions
diff --git a/dgit b/dgit
index f9c46c0..9d1570c 100755
--- a/dgit
+++ b/dgit
@@ -24,6 +24,7 @@ use Data::Dumper;
use LWP::UserAgent;
use Dpkg::Control::Hash;
use File::Path;
+use File::Basename;
use Dpkg::Version;
use POSIX;
@@ -35,7 +36,10 @@ our $sign = 1;
our $dryrun = 0;
our $changesfile;
our $new_package = 0;
+our $ignoredirty = 0;
+our $noquilt = 0;
our $existing_package = 'dpkg';
+our $cleanmode = 'dpkg-source';
our %format_ok = map { $_=>1 } ("1.0","3.0 (native)","3.0 (quilt)");
@@ -45,14 +49,19 @@ our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
our (@sbuild) = qw(sbuild -A);
our (@dpkgbuildpackage) = qw(dpkg-buildpackage -i\.git/ -I.git);
+our (@dpkgsource) = qw(dpkg-source -i\.git/ -I.git);
+our (@dpkggenchanges) = qw(dpkg-genchanges);
our (@mergechanges) = qw(mergechanges -f);
-
+our (@changesopts) = ('');
our %opts_opt_map = ('dget' => \@dget,
'dput' => \@dput,
'debsign' => \@debsign,
'sbuild' => \@sbuild,
+ 'dpkg-source' => \@dpkgsource,
'dpkg-buildpackage' => \@dpkgbuildpackage,
+ 'dpkg-genchanges' => \@dpkggenchanges,
+ 'ch' => \@changesopts,
'mergechanges' => \@mergechanges);
our $keyid;
@@ -61,7 +70,7 @@ our $debug = 0;
open DEBUG, ">/dev/null" or die $!;
our $remotename = 'dgit';
-our $ourdscfield = 'Vcs-Dgit-Master';
+our @ourdscfield = qw(Dgit Vcs-Dgit-Master);
our $branchprefix = 'dgit';
our $csuite;
@@ -76,7 +85,18 @@ sub debiantag ($) {
return "debian/$v";
}
-sub dscfn ($) { return "${package}_$_[0].dsc"; }
+sub stripepoch ($) {
+ my ($vsn) = @_;
+ $vsn =~ s/^\d+\://;
+ return $vsn;
+}
+
+sub dscfn ($) {
+ my ($vsn) = @_;
+ return "${package}_".(stripepoch $vsn).".dsc";
+}
+
+sub changesopts () { return @changesopts[1..$#changesopts]; }
our $us = 'dgit';
@@ -221,13 +241,13 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit.default.ssh' => 'ssh',
'dgit-distro.debian.git-host' => 'git.debian.org',
'dgit-distro.debian.git-proto' => 'git+ssh://',
- 'dgit-distro.debian.git-path' => '/git/dgit-repos',
+ 'dgit-distro.debian.git-path' => '/git/dgit-repos/repos',
'dgit-distro.debian.git-check' => 'ssh-cmd',
'dgit-distro.debian.git-create' => 'ssh-cmd',
'dgit-distro.debian.sshdakls-host' => 'coccia.debian.org',
'dgit-distro.debian.sshdakls-dir' =>
'/srv/ftp-master.debian.org/ftp/dists',
- 'dgit-distro.debian.mirror' => 'http://http.debian.net/debian/');
+ 'dgit-distro.debian.mirror' => 'http://ftp.debian.org/debian/');
sub cfg {
foreach my $c (@_) {
@@ -390,7 +410,7 @@ sub madison_parse ($) {
}
$5 eq 'source' or die "$rmad ?";
my $prefix = substr($package, 0, $package =~ m/^l/ ? 4 : 1);
- my $subpath = "/pool/$component/$prefix/$package/${package}_$vsn.dsc";
+ my $subpath = "/pool/$component/$prefix/$package/".dscfn($vsn);
push @out, [$vsn,$subpath,$newsuite];
}
return sort { -version_compare_string($a->[0],$b->[0]); } @out;
@@ -406,6 +426,8 @@ sub canonicalise_suite_madison ($$) {
}
sub canonicalise_suite () {
+ return if defined $csuite;
+ fail "cannot operate on $isuite suite" if $isuite eq 'UNRELEASED';
$csuite = archive_query('canonicalise_suite');
if ($isuite ne $csuite) {
# madison canonicalises for us
@@ -421,8 +443,6 @@ sub get_archive_dsc () {
$dscurl = access_cfg('mirror').$subpath;
$dscdata = url_get($dscurl);
next unless defined $dscdata;
- $dscurl = access_cfg('mirror').$subpath;
- $dscdata = url_get($dscurl);
my $dscfh = new IO::File \$dscdata, '<' or die $!;
print DEBUG Dumper($dscdata) if $debug>1;
$dsc = parsecontrolfh($dscfh,$dscurl, allow_pgp=>1);
@@ -479,7 +499,7 @@ sub mktree_in_ud_from_only_subdir () {
$dirs[0] =~ m#^([^/]+)/\.$# or die;
my $dir = $1;
chdir $dir or die "$dir $!";
- die if stat '.git';
+ fail "source package contains .git directory" if stat '.git';
die $! unless $!==&ENOENT;
runcmd qw(git init -q);
rmtree('.git/objects');
@@ -490,16 +510,35 @@ sub mktree_in_ud_from_only_subdir () {
return ($tree,$dir);
}
-sub dsc_files () {
- my $field = $dsc->{'Checksums-Sha256'} || $dsc->{Files};
- defined $field or
- fail "missing both Checksums-Sha256 and Files in ".
+sub dsc_files_info () {
+ foreach my $csumi (['Checksums-Sha256','Digest::SHA', 'new(256)'],
+ ['Checksums-Sha1', 'Digest::SHA', 'new(1)'],
+ ['Files', 'Digest::MD5', 'new()']) {
+ my ($fname, $module, $method) = @$csumi;
+ my $field = $dsc->{$fname};
+ next unless defined $field;
+ eval "use $module; 1;" or die $@;
+ my @out;
+ foreach (split /\n/, $field) {
+ next unless m/\S/;
+ m/^(\w+) (\d+) (\S+)$/ or
+ fail "could not parse .dsc $fname line \`$_'";
+ my $digester = eval "$module"."->$method;" or die $@;
+ push @out, {
+ Hash => $1,
+ Bytes => $2,
+ Filename => $3,
+ Digester => $digester,
+ };
+ }
+ return @out;
+ }
+ fail "missing any supported Checksums-* or Files field in ".
$dsc->get_option('name');
- map {
- m/^\w+ \d+ (\S+)$/ or
- fail "could not parse .dsc Files/Checksums line \`$_'";
- $1;
- } grep m/\S/, split /\n/, $field;
+}
+
+sub dsc_files () {
+ map { $_->{Filename} } dsc_files_info();
}
sub is_orig_file ($) {
@@ -582,12 +621,9 @@ Last allegedly pushed/uploaded: $oversion (newer or same)
$later_warning_msg
END
$outputhash = $upload_hash;
- } elsif ($outputhash ne $upload_hash) {
- fail "version in archive ($cversion)".
- " is same as version in git".
- " to-be-uploaded (upload/) branch ($oversion)".
- " but archive version hash no commit hash?!";
- }
+ } else {
+ $outputhash = $upload_hash;
+ }
}
chdir '../../../..' or die $!;
runcmd @git, qw(update-ref -m),"dgit fetch import $cversion",
@@ -599,10 +635,20 @@ END
}
sub ensure_we_have_orig () {
- foreach my $f (dsc_files()) {
+ foreach my $fi (dsc_files_info()) {
+ my $f = $fi->{Filename};
next unless is_orig_file($f);
- if (stat "../$f") {
- die "$f ?" unless -f _;
+ if (open F, "<", "../$f") {
+ $fi->{Digester}->reset();
+ $fi->{Digester}->addfile(*F);
+ F->error and die $!;
+ my $got = $fi->{Digester}->hexdigest();
+ $got eq $fi->{Hash} or
+ fail "existing file $f has hash $got but .dsc".
+ " demands hash $fi->{Hash}".
+ " (perhaps you should delete this file?)";
+ print "using existing $f\n";
+ next;
} else {
die "$f $!" unless $!==&ENOENT;
}
@@ -622,8 +668,14 @@ sub rev_parse ($) {
sub is_fast_fwd ($$) {
my ($ancestor,$child) = @_;
- my $mb = cmdoutput @git, qw(merge-base), $ancestor, $child;
- return rev_parse($mb) eq rev_parse($ancestor);
+ my @cmd = (@git, qw(merge-base), $ancestor, $child);
+ my $mb = cmdoutput_errok @cmd;
+ if (defined $mb) {
+ return rev_parse($mb) eq rev_parse($ancestor);
+ } else {
+ $?==256 or failedcmd @cmd;
+ return 0;
+ }
}
sub git_fetch_us () {
@@ -635,7 +687,10 @@ sub fetch_from_archive () {
# ensures that lrref() is what is actually in the archive,
# one way or another
get_archive_dsc() or return 0;
- $dsc_hash = $dsc->{$ourdscfield};
+ foreach my $field (@ourdscfield) {
+ $dsc_hash = $dsc->{$field};
+ last if defined $dsc_hash;
+ }
if (defined $dsc_hash) {
$dsc_hash =~ m/\w+/ or fail "invalid hash in .dsc \`$dsc_hash'";
$dsc_hash = $&;
@@ -737,6 +792,7 @@ sub pull () {
}
sub check_not_dirty () {
+ return if $ignoredirty;
my @cmd = (@git, qw(diff --quiet HEAD));
printcmd(\*DEBUG,"+",@cmd) if $debug>0;
$!=0; $?=0; system @cmd;
@@ -748,24 +804,39 @@ sub check_not_dirty () {
}
}
-sub commit_quilty_patch ($) {
- my ($vsn) = @_;
+sub commit_quilty_patch () {
my $output = cmdoutput @git, qw(status --porcelain);
- my %fixups = map {$_=>1}
- (".pc/debian-changes-$vsn/","debian/patches/debian-changes-$vsn");
- my @files;
+ my %adds;
+ my $bad=0;
foreach my $l (split /\n/, $output) {
- next unless $l =~ s/^\?\? //;
- next unless $fixups{$l};
- push @files, $l;
+ next unless $l =~ m/\S/;
+ if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
+ $adds{$1}++;
+ } else {
+ print STDERR "git status: $l\n";
+ $bad++;
+ }
+ }
+ fail "unexpected output from git status (is tree clean?)" if $bad;
+ if (!%adds) {
+ print "nothing quilty to commit, ok.\n";
+ return;
}
- print DEBUG "checking for quilty\n", Dumper(\@files);
- if (@files == 2) {
- my $m = "Commit Debian 3.0 (quilt) metadata";
- print "$m\n";
- runcmd_ordryrun @git, qw(add), @files;
- runcmd_ordryrun @git, qw(commit -m), $m;
+ runcmd_ordryrun @git, qw(add), sort keys %adds;
+ my $m = "Commit Debian 3.0 (quilt) metadata";
+ print "$m\n";
+ runcmd_ordryrun @git, qw(commit -m), $m;
+}
+
+sub madformat ($) {
+ my ($format) = @_;
+ return 0 unless $format eq '3.0 (quilt)';
+ print "Format \`$format', urgh\n";
+ if ($noquilt) {
+ print "Not doing any fixup of \`$format' due to --no-quilt-fixup";
+ return 0;
}
+ return 1;
}
sub dopush () {
@@ -785,9 +856,8 @@ sub dopush () {
fail "$dsc is for $dscpackage $dversion".
" but debian/changelog is for $package $cversion";
print DEBUG "format $format\n";
- if ($format eq '3.0 (quilt)') {
- print "Format \`$format', urgh\n";
- commit_quilty_patch($dversion);
+ if (madformat($format)) {
+ commit_quilty_patch();
}
check_not_dirty();
prep_ud();
@@ -813,15 +883,15 @@ sub dopush () {
# runcmd @git, qw(fetch -p ), "$alioth_git/$package.git",
# map { lref($_).":".rref($_) }
# (uploadbranch());
- $dsc->{$ourdscfield} = rev_parse('HEAD');
+ $dsc->{$ourdscfield[0]} = rev_parse('HEAD');
$dsc->save("../$dscfn.tmp") or die $!;
if (!$changesfile) {
- my $multi = "../${package}_${cversion}_multi.changes";
+ my $multi = "../${package}_".(stripepoch $cversion)."_multi.changes";
if (stat "$multi") {
$changesfile = $multi;
} else {
$!==&ENOENT or die "$multi: $!";
- my $pat = "${package}_${cversion}_*.changes";
+ my $pat = "${package}_".(stripepoch $cversion)."_*.changes";
my @cs = glob "../$pat";
fail "failed to find unique changes file".
" (looked for $pat in .., or $multi);".
@@ -830,6 +900,12 @@ sub dopush () {
($changesfile) = @cs;
}
}
+ my $changes = parsecontrol($changesfile,$changesfile);
+ foreach my $field (qw(Source Distribution Version)) {
+ $changes->{$field} eq $clogp->{$field} or
+ fail "changes field $field \`$changes->{$field}'".
+ " does not match changelog \`$clogp->{$field}'";
+ }
my $tag = debiantag($dversion);
if (!check_for_git()) {
create_remote_git_repo();
@@ -926,7 +1002,7 @@ sub cmd_pull {
sub cmd_push {
parseopts();
badusage "-p is not allowed with dgit push" if defined $package;
- runcmd @git, qw(diff --quiet HEAD);
+ check_not_dirty();
my $clogp = parsechangelog();
$package = getfield $clogp, 'Source';
if (@ARGV==0) {
@@ -942,7 +1018,10 @@ sub cmd_push {
git_fetch_us();
}
if (fetch_from_archive()) {
- is_fast_fwd(lrref(), 'HEAD') or die;
+ is_fast_fwd(lrref(), 'HEAD') or
+ fail "dgit push: HEAD is not a descendant".
+ " of the archive's version.\n".
+ "$us: To overwrite it, use git-merge -s ours ".lrref().".";
} else {
$new_package or
fail "package appears to be new in this suite;".
@@ -951,35 +1030,149 @@ sub cmd_push {
dopush();
}
-sub cmd_build {
- # we pass further options and args to git-buildpackage
- badusage "-p is not allowed with dgit build" if defined $package;
+our $version;
+our $sourcechanges;
+our $dscfn;
+
+our $fakeeditorenv = 'DGIT_FAKE_EDITOR_QUILT';
+
+sub build_maybe_quilt_fixup () {
+ if (!open F, "debian/source/format") {
+ die $! unless $!==&ENOENT;
+ return;
+ }
+ $_ = <F>;
+ F->error and die $!;
+ chomp;
+ return unless madformat($_);
+ # sigh
+ my $clogp = parsechangelog();
+ my $version = getfield $clogp, 'Version';
+ my $author = getfield $clogp, 'Maintainer';
+ my $headref = rev_parse('HEAD');
+ my $time = time;
+ my $ncommits = 3;
+ my $patchname = "auto-$version-$headref-$time";
+ my $msg = cmdoutput @git, qw(log), "-n$ncommits";
+ my $descfn = ".git/dgit/quilt-description.tmp";
+ open O, '>', $descfn or die "$descfn: $!";
+ $msg =~ s/\n/\n /g;
+ $msg =~ s/^\s+$/ ./mg;
+ print O <<END or die $!;
+Description: Automatically generated patch ($clogp->{Version})
+ Last (up to) $ncommits git changes, FYI:
+ .
+ $msg
+Author: $author
+
+---
+
+END
+ close O or die $!;
+ {
+ local $ENV{'EDITOR'} = cmdoutput qw(realpath --), $0;
+ local $ENV{'VISUAL'} = $ENV{'EDITOR'};
+ local $ENV{$fakeeditorenv} = cmdoutput qw(realpath --), $descfn;
+ runcmd_ordryrun @dpkgsource, qw(--commit .), $patchname;
+ }
+
+ if (!open P, '>>', ".pc/applied-patches") {
+ $!==&ENOENT or die $!;
+ } else {
+ close P;
+ }
+
+ commit_quilty_patch();
+}
+
+sub quilt_fixup_editor () {
+ my $descfn = $ENV{$fakeeditorenv};
+ my $editing = $ARGV[$#ARGV];
+ open I1, '<', $descfn or die "$descfn: $!";
+ open I2, '<', $editing or die "$editing: $!";
+ unlink $editing or die "$editing: $!";
+ open O, '>', $editing or die "$editing: $!";
+ while (<I1>) { print O or die $!; } I1->error and die $!;
+ my $copying = 0;
+ while (<I2>) {
+ $copying ||= m/^\-\-\- /;
+ next unless $copying;
+ print O or die $!;
+ }
+ I2->error and die $!;
+ close O or die $1;
+ exit 0;
+}
+
+sub build_prep () {
+ badusage "-p is not allowed when building" if defined $package;
+ check_not_dirty();
my $clogp = parsechangelog();
$isuite = getfield $clogp, 'Distribution';
$package = getfield $clogp, 'Source';
+ $version = getfield $clogp, 'Version';
+ build_maybe_quilt_fixup();
+}
+
+sub cmd_build {
+ badusage "dgit build implies --clean=dpkg-source"
+ if $cleanmode ne 'dpkg-source';
+ build_prep();
+ runcmd_ordryrun @dpkgbuildpackage, qw(-us -uc), changesopts(), @ARGV;
+ printdone "build successful\n";
+}
+
+sub cmd_git_build {
+ badusage "dgit git-build implies --clean=dpkg-source"
+ if $cleanmode ne 'dpkg-source';
+ build_prep();
my @cmd =
(qw(git-buildpackage -us -uc --git-no-sign-tags),
"--git-builder=@dpkgbuildpackage");
- unless (grep { m/^--git-debian-branch/ } @ARGV) {
+ unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
canonicalise_suite();
push @cmd, "--git-debian-branch=".lbranch();
}
+ push @cmd, changesopts();
runcmd_ordryrun @cmd, @ARGV;
printdone "build successful\n";
}
+sub build_source {
+ build_prep();
+ $sourcechanges = "${package}_".(stripepoch $version)."_source.changes";
+ $dscfn = dscfn($version);
+ if ($cleanmode eq 'dpkg-source') {
+ runcmd_ordryrun (@dpkgbuildpackage, qw(-us -uc -S)), changesopts();
+ } else {
+ if ($cleanmode eq 'git') {
+ runcmd_ordryrun @git, qw(clean -xdf);
+ } elsif ($cleanmode eq 'none') {
+ } else {
+ die "$cleanmode ?";
+ }
+ my $pwd = cmdoutput qw(env - pwd);
+ my $leafdir = basename $pwd;
+ chdir ".." or die $!;
+ runcmd_ordryrun @dpkgsource, qw(-b --), $leafdir;
+ chdir $pwd or die $!;
+ runcmd_ordryrun qw(sh -ec),
+ 'exec >$1; shift; exec "$@"','x',
+ "../$sourcechanges",
+ @dpkggenchanges, qw(-S), changesopts();
+ }
+}
+
+sub cmd_build_source {
+ badusage "build-source takes no additional arguments" if @ARGV;
+ build_source();
+ printdone "source built, results in $dscfn and $sourcechanges";
+}
+
sub cmd_sbuild {
- check_not_dirty();
- badusage "-p is not allowed with dgit sbuild" if defined $package;
- my $clogp = parsechangelog();
- $package = getfield $clogp, 'Source';
- my $isuite = getfield $clogp, 'Distribution';
- my $version = getfield $clogp, 'Version';
- runcmd_ordryrun (@dpkgbuildpackage, qw(-us -uc -S));
+ build_source();
chdir ".." or die $!;
- my $sourcechanges = "${package}_${version}_source.changes";
- my $dscfn = dscfn($version);
- my $pat = "${package}_${version}_*.changes";
+ my $pat = "${package}_".(stripepoch $version)."_*.changes";
if (!$dryrun) {
stat $dscfn or fail "$dscfn (in parent directory): $!";
stat $sourcechanges or fail "$sourcechanges (in parent directory): $!";
@@ -990,7 +1183,7 @@ sub cmd_sbuild {
}
runcmd_ordryrun @sbuild, @ARGV, qw(-d), $isuite, $dscfn;
runcmd_ordryrun @mergechanges, glob $pat;
- my $multichanges = "${package}_${version}_multi.changes";
+ my $multichanges = "${package}_".(stripepoch $version)."_multi.changes";
if (!$dryrun) {
stat $multichanges or fail "$multichanges: $!";
}
@@ -998,9 +1191,10 @@ sub cmd_sbuild {
}
sub cmd_quilt_fixup {
- badusage "incorrect arguments to dgit quilt-fixup";
+ badusage "incorrect arguments to dgit quilt-fixup" if @ARGV;
my $clogp = parsechangelog();
- commit_quilty_patch((getfield $clogp, 'Version'));
+ $version = getfield $clogp, 'Version';
+ build_maybe_quilt_fixup();
}
sub parseopts () {
@@ -1018,14 +1212,25 @@ sub parseopts () {
helponly();
} elsif (m/^--new$/) {
$new_package=1;
- } elsif (m/^--(\w+)=(.*)/s && ($om = $opts_opt_map{$1})) {
+ } elsif (m/^--(\w+)=(.*)/s &&
+ ($om = $opts_opt_map{$1}) &&
+ length $om->[0]) {
$om->[0] = $2;
- } elsif (m/^--(\w+):(.*)/s && ($om = $opts_opt_map{$1})) {
+ } elsif (m/^--(\w+):(.*)/s &&
+ ($om = $opts_opt_map{$1})) {
push @$om, $2;
} elsif (m/^--existing-package=(.*)/s) {
$existing_package = $1;
} elsif (m/^--distro=(.*)/s) {
$idistro = $1;
+ } elsif (m/^--clean=(dpkg-source|git|none)$/s) {
+ $cleanmode = $1;
+ } elsif (m/^--clean=(.*)$/s) {
+ badusage "unknown cleaning mode \`$1'";
+ } elsif (m/^--ignore-dirty$/s) {
+ $ignoredirty = 1;
+ } elsif (m/^--no-quilt-fixup$/s) {
+ $noquilt = 1;
} else {
badusage "unknown long option \`$_'";
}
@@ -1040,6 +1245,9 @@ sub parseopts () {
$debug++;
} elsif (s/^-N/-/) {
$new_package=1;
+ } elsif (m/^-[vm]/) {
+ push @changesopts, $_;
+ $_ = '';
} elsif (s/^-c(.*=.*)//s) {
push @git, '-c', $1;
} elsif (s/^-d(.*)//s) {
@@ -1048,6 +1256,12 @@ sub parseopts () {
$changesfile = $1;
} elsif (s/^-k(.*)//s) {
$keyid=$1;
+ } elsif (s/^-wn//s) {
+ $cleanmode = 'none';
+ } elsif (s/^-wg//s) {
+ $cleanmode = 'git';
+ } elsif (s/^-wd//s) {
+ $cleanmode = 'dpkg-source';
} else {
badusage "unknown short option \`$_'";
}
@@ -1056,6 +1270,12 @@ sub parseopts () {
}
}
+if ($ENV{$fakeeditorenv}) {
+ quilt_fixup_editor();
+}
+
+delete $ENV{'DGET_UNPACK'};
+
parseopts();
print STDERR "DRY RUN ONLY\n" if $dryrun;
if (!@ARGV) {