summaryrefslogtreecommitdiff
path: root/dgit
diff options
context:
space:
mode:
Diffstat (limited to 'dgit')
-rwxr-xr-xdgit2
1 files changed, 2 insertions, 0 deletions
diff --git a/dgit b/dgit
index da4e57c..fc310d5 100755
--- a/dgit
+++ b/dgit
@@ -565,6 +565,8 @@ sub check_not_dirty () {
sub dopush () {
runcmd @git, qw(diff --quiet HEAD);
+ print DEBUG "actually entering push\n";
+ runcmd qw(debian/rules clean);
my $clogp = parsechangelog();
$package = $clogp->{Source};
my $dscfn = "${package}_$clogp->{Version}.dsc";