summaryrefslogtreecommitdiff
path: root/po4a/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'po4a/Makefile')
-rw-r--r--po4a/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/po4a/Makefile b/po4a/Makefile
index c759ce8..e88aded 100644
--- a/po4a/Makefile
+++ b/po4a/Makefile
@@ -75,6 +75,11 @@
# tree.
#
# make targets: install
+#
+# Check:
+#
+# make targets: check
+# pairwise-pocheck.check
default: pofiles
@@ -84,6 +89,8 @@ PO4A ?= po4a
all update: translated
+check: po4a.cfg.check pairwise-pocheck.check
+
pofiles: po4a.cfg
$(PO4A) --no-translations $<
@@ -97,10 +104,13 @@ po4a.cfg.check: list-documents
./$< >$@.tmp
diff po4a.cfg $@.tmp
+pairwise-pocheck.check:
+ ./pairwise-pocheck
+
t = ../.po4a.translated-only
p = ../po4a
-translated-only: po4a.cfg
+translated-only: po4a.cfg pairwise-pocheck.check
rm -rf $t && mkdir $t
cd $t && ln -s $p/*.po $p/*.pot $p/po4a.cfg .
cd $t && $(PO4A) po4a.cfg
@@ -114,7 +124,11 @@ translated-only: po4a.cfg
.PRECIOUS: .po4a.%.cfg
-preview.%: .po4a.%.cfg
+pairwise-pocheck.%.check:
+ @tclsh /dev/null || printf ':;:; Please run apt-get install tcl\n'
+ ./pairwise-pocheck $*
+
+preview.%: .po4a.%.cfg pairwise-pocheck.%.check
$S $(PO4A) $<
$S ./install-documents >/dev/null .$*.translated $@
@ echo '# runes to preview the various final tranlated manpages:'