summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/tests/Makefile b/tests/Makefile
index e6ce153..8494284 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -7,19 +7,12 @@ TESTSCRIPTS ?= $(shell tests/enumerate-tests)
TESTNAMES := $(notdir $(TESTSCRIPTS))
all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
- @echo "ALL PASSED"
-
-tests/tmp:
- mkdir -p $@
+ @echo "ALL PASSED$${DGIT_TESTS_PROGRESSIVE+ AT SOME POINT}"
+tests/tmp/%.ok:
ifeq ($(DGIT_TEST_RETRY_COUNT),)
-
-tests/tmp/%.ok: tests/tmp
tests/tests/$* >tests/tmp/$*.log 2>&1
-
else
-
-tests/tmp/%.ok: tests/tmp
@for retry in $$( seq 1 $(DGIT_TEST_RETRY_COUNT) ); do \
echo "[$$retry] $*"; \
tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
@@ -27,5 +20,5 @@ tests/tmp/%.ok: tests/tmp
if [ $$rc = 0 ]; then exit 0; fi; \
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \
done; exit $$rc
-
endif
+ @touch $@