summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/tests/Makefile b/tests/Makefile
index e6ce153..44b7458 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -12,14 +12,11 @@ all: $(foreach t,$(TESTNAMES),tests/tmp/$t.ok)
tests/tmp:
mkdir -p $@
-ifeq ($(DGIT_TEST_RETRY_COUNT),)
tests/tmp/%.ok: tests/tmp
+ifeq ($(DGIT_TEST_RETRY_COUNT),)
tests/tests/$* >tests/tmp/$*.log 2>&1
-
else
-
-tests/tmp/%.ok: tests/tmp
@for retry in $$( seq 1 $(DGIT_TEST_RETRY_COUNT) ); do \
echo "[$$retry] $*"; \
tests/tests/$* >tests/tmp/$*.$$retry.log 2>&1; \
@@ -27,5 +24,4 @@ tests/tmp/%.ok: tests/tmp
if [ $$rc = 0 ]; then exit 0; fi; \
echo >&2 "[$$retry] $* TEST FAILED $$rc"; \
done; exit $$rc
-
endif